SMS 2FA Disruption Due to Twilio Outage

Incident Report for BigCommerce

Resolved

All Twilio services impacted by the AWS outage affecting the US-1 Region have recovered and are operating as intended.
Posted Oct 20, 2025 - 21:52 CDT

Identified

Commerce engineers are aware of an ongoing Twilio outage impacting SMS-based two-factor authentication (2FA). If you're affected, please contact Support to temporarily switch to email-based 2SV. For further service health updates, visit https://status.twilio.com
Posted Oct 20, 2025 - 04:57 CDT