Intermittent Availability Issues

Incident Report for BigCommerce

Resolved

Commerce engineers observed an elevated error rate affecting a subset of stores beginning at 21:40 UTC. Action was taken and at 21:55 error rates have returned to normal.
Posted Oct 20, 2025 - 17:25 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 17:08 CDT

Investigating

BigCommerce engineers are currently investigating intermittent availability issues with a subset of stores. We will provide an update shortly.
Posted Oct 20, 2025 - 16:53 CDT
This incident affected: Storefront.