Availability Issues in European Region

Incident Report for BigCommerce

Resolved

BigCommerce engineers observed an availability issue with a subset of stores in the EU region beginning at approximately 15:01 UTC, which caused some storefront requests to fail. The issue was resolved at 15:26 UTC and all services are fully operational.
Posted Jun 24, 2025 - 10:50 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2025 - 10:31 CDT

Investigating

BigCommerce engineers are investigating an issue impacting the availability of stores in the EU region. We will provide further information as it becomes available.
Posted Jun 24, 2025 - 10:15 CDT
This incident affected: Storefront.