Webhooks delayed

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Oct 12, 2025 - 10:41 CDT

Investigating

We are continuing to investigate this issue.
Posted Oct 12, 2025 - 10:34 CDT

Monitoring

Webhooks delivery rate has returned to normal. Commerce engineers are continuing to monitor.
Posted Oct 12, 2025 - 10:34 CDT

Investigating

Commerce engineers are investigating a delay in webhooks processing for a subset of stores.
Posted Oct 12, 2025 - 09:46 CDT
This incident affected: API & Webhooks.