BigCommerce engineers observed an availability issue with a subset of stores beginning at approximately 15:58 UTC affecting API, storefront, and control panel requests. The issue was resolved at 16:44 UTC and all services are fully operational.
Posted Mar 25, 2025 - 11:55 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 11:46 CDT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2025 - 11:30 CDT
Investigating
BigCommerce engineers are currently investigating intermittent availability issues with a subset of stores. We will provide an update shortly.
Posted Mar 25, 2025 - 11:04 CDT
This incident affected: Control Panel and Storefront.