Slow search performance

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 07:43 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2025 - 07:36 CDT

Identified

A subset of stores in the EU region are experiencing slow search times on products and the control panel. BigCommerce engineers have identified the issue and are implementing a fix.
Posted Jun 23, 2025 - 07:11 CDT
This incident affected: Control Panel and Storefront.